summaryrefslogtreecommitdiff
path: root/modules/nixos/thunderbird.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/thunderbird.nix')
-rw-r--r--modules/nixos/thunderbird.nix64
1 files changed, 31 insertions, 33 deletions
diff --git a/modules/nixos/thunderbird.nix b/modules/nixos/thunderbird.nix
index 5afb163..2261dcd 100644
--- a/modules/nixos/thunderbird.nix
+++ b/modules/nixos/thunderbird.nix
@@ -14,39 +14,37 @@ in {
"x-scheme-handler/mailto"
];
- hm = {
- programs.thunderbird = {
- enable = true;
- profiles.default = {
- isDefault = true;
- withExternalGnupg = true;
- };
- settings = {
- "app.update.auto" = false;
- "browser.display.document_color_use" = 2;
- "browser.display.use_system_colors" = true;
- "browser.search.region" = "US";
- "browser.search.update" = false;
- "datareporting.healthreport.uploadEnabled" = false;
- "full-screen-api.warning.delay" = 0;
- "full-screen-api.warning.timeout" = 0;
- "general.autoScroll" = true;
- "general.smoothScroll" = true;
- "mail.default_send_format" = 0;
- "mail.tabs.drawInTitlebar" =
- if config.nixfiles.modules.kde.enable
- then 1
- else 0;
- "mailnews.start_page.url" = "about:blank";
- "media.autoplay.blocking_policy" = 2;
- "media.autoplay.default" = 5;
- "media.autoplay.enabled" = false;
- "media.hardwaremediakeys.enabled" = false;
- "network.cookie.cookieBehavior" = 2;
- "places.history.enabled" = false;
- "reader.parse-on-load.enabled" = false;
- "toolkit.legacyUserProfileCustomizations.stylesheets" = true;
- };
+ hm.programs.thunderbird = {
+ enable = true;
+ profiles.default = {
+ isDefault = true;
+ withExternalGnupg = true;
+ };
+ settings = {
+ "app.update.auto" = false;
+ "browser.display.document_color_use" = 2;
+ "browser.display.use_system_colors" = true;
+ "browser.search.region" = "US";
+ "browser.search.update" = false;
+ "datareporting.healthreport.uploadEnabled" = false;
+ "full-screen-api.warning.delay" = 0;
+ "full-screen-api.warning.timeout" = 0;
+ "general.autoScroll" = true;
+ "general.smoothScroll" = true;
+ "mail.default_send_format" = 0;
+ "mail.tabs.drawInTitlebar" =
+ if config.nixfiles.modules.kde.enable
+ then 1
+ else 0;
+ "mailnews.start_page.url" = "about:blank";
+ "media.autoplay.blocking_policy" = 2;
+ "media.autoplay.default" = 5;
+ "media.autoplay.enabled" = false;
+ "media.hardwaremediakeys.enabled" = false;
+ "network.cookie.cookieBehavior" = 2;
+ "places.history.enabled" = false;
+ "reader.parse-on-load.enabled" = false;
+ "toolkit.legacyUserProfileCustomizations.stylesheets" = true;
};
};
};