summaryrefslogtreecommitdiff
path: root/modules/nixos/wayland.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/wayland.nix')
-rw-r--r--modules/nixos/wayland.nix10
1 files changed, 7 insertions, 3 deletions
diff --git a/modules/nixos/wayland.nix b/modules/nixos/wayland.nix
index b64ab32..e3dba79 100644
--- a/modules/nixos/wayland.nix
+++ b/modules/nixos/wayland.nix
@@ -4,12 +4,16 @@
pkgs,
...
}:
-with lib; let
+with lib;
+let
cfg = config.nixfiles.modules.wayland;
-in {
+in
+{
options.nixfiles.modules.wayland.enable = mkEnableOption "Wayland";
config = mkIf cfg.enable {
- hm.home.packages = with pkgs; [wl-clipboard];
+ nixfiles.modules.foot.enable = true;
+
+ hm.home.packages = with pkgs; [ wl-clipboard ];
};
}