summaryrefslogtreecommitdiff
path: root/modules/nsd.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nsd.nix')
-rw-r--r--modules/nsd.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/modules/nsd.nix b/modules/nsd.nix
index f44a2a0..9adc084 100644
--- a/modules/nsd.nix
+++ b/modules/nsd.nix
@@ -225,5 +225,15 @@ in
allowedTCPPorts = [ 53 ];
allowedUDPPorts = allowedTCPPorts;
};
+
+ topology = with cfg; {
+ nodes.${this.hostname}.services.nsd = {
+ name = "NSD";
+ icon = "${inputs.homelab-svg-assets}/assets/unbound.svg";
+ details.listen.text = concatMapStringsSep "\n" (i: "${i}:53") (
+ filter (i: i != "127.0.0.1" && i != "::1") config.services.nsd.interfaces
+ );
+ };
+ };
};
}