summaryrefslogtreecommitdiff
path: root/modules/postgresql.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/postgresql.nix')
-rw-r--r--modules/postgresql.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/modules/postgresql.nix b/modules/postgresql.nix
index 5081340..f9ea64f 100644
--- a/modules/postgresql.nix
+++ b/modules/postgresql.nix
@@ -1,5 +1,6 @@
{
config,
+ inputs,
lib,
pkgs,
this,
@@ -94,5 +95,13 @@ in
\unset QUIET
''
);
+
+ topology = {
+ nodes.${this.hostname}.services.postgresql = {
+ name = "PostgreSQL";
+ icon = "${inputs.homelab-svg-assets}/assets/postgresql.svg";
+ details.listen.text = "127.0.0.1:5432";
+ };
+ };
};
}