about summary refs log tree commit diff
path: root/modules/profiles/dev/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/profiles/dev/default.nix')
-rw-r--r--modules/profiles/dev/default.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/modules/profiles/dev/default.nix b/modules/profiles/dev/default.nix
index af151a1..38a2117 100644
--- a/modules/profiles/dev/default.nix
+++ b/modules/profiles/dev/default.nix
@@ -16,6 +16,10 @@ in
 
   config = mkIf cfg.enable {
     nixfiles.modules = {
+      common.nix.allowedUnfreePackages = [
+        "terraform" # source-available
+      ];
+
       bat.enable = true;
       curl.enable = true;
       direnv.enable = true;
@@ -59,10 +63,12 @@ in
         };
 
         packages = with pkgs; [
+          (google-cloud-sdk.withExtraComponents [
+            google-cloud-sdk.components.gke-gcloud-auth-plugin
+          ])
           age
           dbeaver-bin
           distrobox
-          google-cloud-sdk
           htmlq
           httpie
           hydra-check
@@ -71,9 +77,11 @@ in
           logcli
           nix-update
           nixpkgs-review
+          opentofu
           scaleway-cli
           sops
           sqlitebrowser
+          terraform
           toolbox
           vultr-cli
           yq

Consider giving Nix/NixOS a try! <3