about summary refs log tree commit diff
path: root/modules/prometheus.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/prometheus.nix')
-rw-r--r--modules/prometheus.nix61
1 files changed, 0 insertions, 61 deletions
diff --git a/modules/prometheus.nix b/modules/prometheus.nix
deleted file mode 100644
index 031b0b2..0000000
--- a/modules/prometheus.nix
+++ /dev/null
@@ -1,61 +0,0 @@
-{
-  config,
-  inputs,
-  lib,
-  libNginx,
-  this,
-  ...
-}:
-let
-  cfg = config.nixfiles.modules.prometheus;
-in
-{
-  options.nixfiles.modules.prometheus = {
-    enable = lib.mkEnableOption "Prometheus";
-
-    port = lib.mkOption {
-      description = "Port.";
-      type = lib.types.port;
-      default = 30111;
-    };
-
-    domain = lib.mkOption {
-      description = "Domain name sans protocol scheme.";
-      type = lib.types.str;
-      default = "prometheus.${config.networking.domain}";
-    };
-  };
-
-  config = lib.mkIf cfg.enable {
-    nixfiles.modules.nginx = {
-      enable = true;
-      upstreams.prometheus.servers."127.0.0.1:${toString cfg.port}" = { };
-      virtualHosts.${cfg.domain} = {
-        locations."/".proxyPass = "http://prometheus";
-        extraConfig = libNginx.config.internalOnly;
-      };
-    };
-
-    services.prometheus = {
-      enable = true;
-      enableReload = true;
-
-      listenAddress = "127.0.0.1";
-      inherit (cfg) port;
-
-      extraFlags = [
-        "--web.external-url=https://${cfg.domain}"
-        "--storage.tsdb.retention.size=50GB"
-        "--storage.tsdb.retention.time=1y"
-        "--storage.tsdb.wal-compression"
-      ];
-    };
-
-    topology.nodes.${this.hostname}.services.prometheus = {
-      name = "Prometheus";
-      icon = "${inputs.homelab-svg-assets}/assets/prometheus.svg";
-      info = cfg.domain;
-      details.listen.text = "127.0.0.1:${toString cfg.port}";
-    };
-  };
-}

Consider giving Nix/NixOS a try! <3