summaryrefslogtreecommitdiff
path: root/modules/sound.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/sound.nix')
-rw-r--r--modules/sound.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/modules/sound.nix b/modules/sound.nix
new file mode 100644
index 0000000..ff90dfc
--- /dev/null
+++ b/modules/sound.nix
@@ -0,0 +1,18 @@
+{ config, lib, ... }:
+with lib;
+let
+ cfg = config.nixfiles.modules.sound;
+in
+{
+ options.nixfiles.modules.sound.enable = mkEnableOption "sound support";
+
+ config = mkIf cfg.enable {
+ services.pipewire = {
+ enable = true;
+
+ alsa.enable = true;
+ jack.enable = true;
+ pulse.enable = true;
+ };
+ };
+}