summaryrefslogtreecommitdiff
path: root/modules/vaultwarden.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/vaultwarden.nix')
-rw-r--r--modules/vaultwarden.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/modules/vaultwarden.nix b/modules/vaultwarden.nix
index 2cacb6c..edce8e5 100644
--- a/modules/vaultwarden.nix
+++ b/modules/vaultwarden.nix
@@ -2,6 +2,7 @@
config,
inputs,
lib,
+ this,
...
}:
with lib;
@@ -141,5 +142,11 @@ in
};
};
};
+
+ topology = with cfg; {
+ nodes.${this.hostname}.services.vaultwarden = {
+ info = mkForce domain;
+ };
+ };
};
}