summaryrefslogtreecommitdiff
path: root/nixosConfigurations/eonwe/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixosConfigurations/eonwe/default.nix')
-rw-r--r--nixosConfigurations/eonwe/default.nix16
1 files changed, 10 insertions, 6 deletions
diff --git a/nixosConfigurations/eonwe/default.nix b/nixosConfigurations/eonwe/default.nix
index 5de3315..1545925 100644
--- a/nixosConfigurations/eonwe/default.nix
+++ b/nixosConfigurations/eonwe/default.nix
@@ -16,7 +16,7 @@ with lib; {
games = {
lutris.enable = true;
- # minecraft.client.enable = true; # FIXME Build fails.
+ minecraft.client.enable = true;
steam.enable = true;
steam-run.quirks.crusaderKings3 = true;
};
@@ -81,10 +81,14 @@ with lib; {
cores = 32;
};
+ # Required[1] for using ZFS kernel modules with "unsupported" kernels.
+ #
+ # [1]: https://github.com/NixOS/nixpkgs/pull/121113#issuecomment-830003344
+ # [1]: https://github.com/NixOS/nixpkgs/pull/230498#issuecomment-1551328615
+ nixpkgs.config.allowBroken = true;
+
boot = {
- # TODO Override Xanmod kernel to support ZFS. This probably will require
- # some patching.
- kernelPackages = config.boot.zfs.package.latestCompatibleLinuxPackages;
+ kernelPackages = pkgs.linuxPackages_xanmod;
kernelParams = [
# Silence benign MCE errors:
@@ -94,8 +98,8 @@ with lib; {
# mce: [Hardware Error]: PROCESSOR 2:a60f12 TIME 1669988017 SOCKET 0 APIC 2 microcode a601201
# ```
"mce=nobootlog"
- # This disables[1] User Mode Instruction Protection (UMIP)[2]. Required
- # for some games to run via Wine.
+ # This disables[1] User Mode Instruction Protection (UMIP)[2]. This is
+ # required for some games to run via Wine.
#
# [1]: https://docs.kernel.org/x86/cpuinfo.html
# [2]: https://en.wikichip.org/wiki/x86/umip