summaryrefslogtreecommitdiff
path: root/nixosConfigurations/iso/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixosConfigurations/iso/default.nix')
-rw-r--r--nixosConfigurations/iso/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/nixosConfigurations/iso/default.nix b/nixosConfigurations/iso/default.nix
new file mode 100644
index 0000000..e435d0b
--- /dev/null
+++ b/nixosConfigurations/iso/default.nix
@@ -0,0 +1,27 @@
+{
+ lib,
+ pkgs,
+ ...
+}:
+with lib; {
+ secrets = mkForce {};
+
+ nixfiles.modules = {
+ git.client.enable = true;
+ openssh = {
+ client.enable = true;
+ server = {
+ enable = true;
+ port = 22;
+ };
+ };
+ };
+
+ programs.mtr.enable = true;
+
+ services.getty.autologinUser = mkForce my.username;
+
+ environment.noXlibs = false;
+
+ nixpkgs.config.allowBroken = true;
+}