summaryrefslogtreecommitdiff
path: root/packages/throttled.nix
diff options
context:
space:
mode:
Diffstat (limited to 'packages/throttled.nix')
-rw-r--r--packages/throttled.nix36
1 files changed, 0 insertions, 36 deletions
diff --git a/packages/throttled.nix b/packages/throttled.nix
deleted file mode 100644
index 1c0f853..0000000
--- a/packages/throttled.nix
+++ /dev/null
@@ -1,36 +0,0 @@
-{
- fetchFromGitHub,
- kmod,
- python3Packages,
- stdenv,
-}:
-stdenv.mkDerivation rec {
- pname = "throttled";
- version = "git";
-
- src = fetchFromGitHub {
- owner = "erpalma";
- repo = pname;
- rev = "1dd726672f0b11b813d4c7b63e0157becde7a013";
- hash = "sha256-0MsPp6y4r/uZB2SplKV+SAiJoxIs2jgOQmQoQQ2ZKwI=";
- };
-
- nativeBuildInputs = with python3Packages; [wrapPython];
-
- pythonPath =
- [kmod]
- ++ (with python3Packages; [configparser dbus-python pygobject3]);
-
- installPhase = ''
- runHook preInstall
-
- install -Dm755 -t $out/opt/throttled throttled.py
- install -Dm644 -t $out/opt/throttled mmio.py
-
- runHook postInstall
- '';
-
- postFixup = ''
- wrapPythonProgramsIn $out/opt/throttled "$out $pythonPath"
- '';
-}