summary refs log tree commit diff
path: root/app-misc/stag/stag-1.0.0.ebuild
diff options
context:
space:
mode:
authorAzat Bahawi <azahi@teknik.io>2020-10-05 08:42:57 +0300
committerGitHub <noreply@github.com>2020-10-05 08:42:57 +0300
commitcdb4996391576265ca57613baabb97529eca38fa (patch)
tree8a6cf953735b7137546839286b03d1e1e687f19f /app-misc/stag/stag-1.0.0.ebuild
parentx11-apps/sx: Update ebuild, bump version (diff)
parentapp-misc/stag: Add live (diff)
Merge pull request #8 from caseyavila/master
app-misc/stag: Add package
Diffstat (limited to 'app-misc/stag/stag-1.0.0.ebuild')
-rw-r--r--app-misc/stag/stag-1.0.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-misc/stag/stag-1.0.0.ebuild b/app-misc/stag/stag-1.0.0.ebuild
new file mode 100644
index 0000000..96d4a7a
--- /dev/null
+++ b/app-misc/stag/stag-1.0.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	inherit git-r3
+	EGIT_REPO_URI="https://github.com/seenaburns/stag.git"
+fi
+
+DESCRIPTION="Streaming bar graphs. For stats and stuff."
+HOMEPAGE="https://github.com/seenaburns/stag"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/seenaburns/stag/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+PATCHES=(
+	"${FILESDIR}/${P}-ncurses.patch"
+)
+
+src_install() {
+	emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}

Consider giving Nix/NixOS a try! <3