summary refs log tree commit diff
path: root/dev-util/bear/bear-2.4.2.ebuild
diff options
context:
space:
mode:
authorazahi <azahi@teknik.io>2019-11-02 01:21:02 +0300
committerazahi <azahi@teknik.io>2019-11-02 01:21:02 +0300
commit00718862fc5a961a65d79060bfb96c508f17df1d (patch)
tree971811e76444c98953e56f147f0b75ba0d3a681d /dev-util/bear/bear-2.4.2.ebuild
parentUpdate TODO.md (diff)
dev-util/bear: Add package
Diffstat (limited to 'dev-util/bear/bear-2.4.2.ebuild')
-rw-r--r--dev-util/bear/bear-2.4.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/bear/bear-2.4.2.ebuild b/dev-util/bear/bear-2.4.2.ebuild
new file mode 100644
index 0000000..8dd684a
--- /dev/null
+++ b/dev-util/bear/bear-2.4.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	SCM="git-r3"
+	EGIT_REPO_URI="https://github.com/rizsotto/Bear"
+fi
+
+inherit cmake-utils ${SCM}
+
+DESCRIPTION="Compilation database generator for Clang"
+HOMEPAGE="https://github.com/rizsotto/Bear"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/rizsotto/Bear/archive/${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-libs/libconfig-1.4"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+if [[ ${PV} != *9999 ]]; then
+	S="${WORKDIR}/Bear-${PV}"
+fi

Consider giving Nix/NixOS a try! <3