summary refs log tree commit diff
path: root/media-fonts/siji/siji-9999.ebuild
diff options
context:
space:
mode:
authorazahi <azahi@teknik.io>2018-12-28 01:22:40 +0300
committerazahi <azahi@teknik.io>2018-12-28 01:22:40 +0300
commit8f2f466965f061ce6d6be4443497c0fe6e10a5bc (patch)
tree9999239cbbac3bab7497b28c44dd75cf499d7f8c /media-fonts/siji/siji-9999.ebuild
Initial
Diffstat (limited to 'media-fonts/siji/siji-9999.ebuild')
-rw-r--r--media-fonts/siji/siji-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-fonts/siji/siji-9999.ebuild b/media-fonts/siji/siji-9999.ebuild
new file mode 100644
index 0000000..dc4630e
--- /dev/null
+++ b/media-fonts/siji/siji-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit git-r3 font
+
+DESCRIPTION="An iconic bitmap font based on Stlarch with additional glyphs"
+HOMEPAGE="https://github.com/stark/siji"
+EGIT_REPO_URI="https://github.com/stark/siji.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="+pcf"
+
+DEPEND="x11-apps/bdftopcf"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+	if use pcf; then
+		bdftopcf bdf/${PN}.bdf -o pcf/${PN}.pcf
+	fi
+}
+
+src_install() {
+	insinto "/usr/share/fonts/${PN}"
+
+	if use pcf; then
+		doins pcf/*
+	else
+		doins bdf/*
+	fi
+}

Consider giving Nix/NixOS a try! <3