summary refs log tree commit diff
path: root/media-fonts/tewi-font/tewi-font-2.0.2.ebuild
diff options
context:
space:
mode:
authorAzat Bahawi <azahi@teknik.io>2020-02-19 16:21:16 +0300
committerAzat Bahawi <azahi@teknik.io>2020-02-19 16:21:16 +0300
commit82f1f31739dece7c1f50b66e6e50ca001254d982 (patch)
tree832411e1a8084f9574f83d9f0048f64ff6cb0df6 /media-fonts/tewi-font/tewi-font-2.0.2.ebuild
parentmedia-fonts/siji: Bump EAPI (diff)
media-fonts/tewi-font: EAPI, remove deprecated PYTHON_COMPAT, versioning
Diffstat (limited to 'media-fonts/tewi-font/tewi-font-2.0.2.ebuild')
-rw-r--r--media-fonts/tewi-font/tewi-font-2.0.2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/media-fonts/tewi-font/tewi-font-2.0.2.ebuild b/media-fonts/tewi-font/tewi-font-2.0.2.ebuild
new file mode 100644
index 0000000..b2fd871
--- /dev/null
+++ b/media-fonts/tewi-font/tewi-font-2.0.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2018-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+if [[ ${PV} == *9999 ]]; then
+	SCM="git-r3"
+	EGIT_REPO_URI="https://github.com/lucy/tewi-font.git"
+fi
+
+inherit font python-any-r1 ${SCM}
+
+DESCRIPTION="A small bitmap font"
+HOMEPAGE="https://github.com/lucy/tewi-font"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/lucy/tewi-font/archive/${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+pcf"
+
+DEPEND="x11-libs/libX11
+	pcf? ( x11-apps/bdftopcf )
+"
+RDEPEND="x11-libs/libX11"
+BDEPEND=""
+
+src_compile() {
+	if use pcf; then
+		emake
+	else
+		emake var
+	fi
+}
+
+src_install() {
+	insinto "/usr/share/fonts/${PN}"
+
+	if use pcf; then
+		doins out/*
+	else
+		doins *.bdf
+	fi
+
+	font_src_install
+}

Consider giving Nix/NixOS a try! <3