summary refs log tree commit diff
path: root/media-fonts/tewi-font/tewi-font-9999.ebuild
diff options
context:
space:
mode:
authorAzat Bahawi <azahi@teknik.io>2021-06-25 20:19:52 +0300
committerAzat Bahawi <azahi@teknik.io>2021-06-25 20:19:52 +0300
commit7528d3496154cd0a8daf8ada7891928798a57565 (patch)
tree62ea3674f48cb378364f6721f77f768ad8299297 /media-fonts/tewi-font/tewi-font-9999.ebuild
parentci: Update TravisCI runner (diff)
meta: Refactor ebuilds and directory structure
- Drop "-rn" (revisions) fork 9999 (live) versions.
- Versioned ebuilds are now symlinked to 9999 (live) versions. This
  should be followed for every package from now on.
- Apply `shfmt` on all ebuilds.
- Update metadata.
Diffstat (limited to 'media-fonts/tewi-font/tewi-font-9999.ebuild')
-rw-r--r--media-fonts/tewi-font/tewi-font-9999.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-fonts/tewi-font/tewi-font-9999.ebuild b/media-fonts/tewi-font/tewi-font-9999.ebuild
new file mode 100644
index 0000000..18b7359
--- /dev/null
+++ b/media-fonts/tewi-font/tewi-font-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	SCM="git-r3"
+	EGIT_REPO_URI="https://github.com/lucy/tewi-font.git"
+fi
+
+inherit font font-ebdftopcf ${SCM}
+
+DESCRIPTION="A small bitmap font"
+HOMEPAGE="https://github.com/lucy/tewi-font"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/lucy/tewi-font/archive/${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+DOCS=(README.md)
+FONT_S=(${S} ${S}/variant)
+
+src_compile() {
+	font-ebdftopcf_src_compile
+}

Consider giving Nix/NixOS a try! <3