summary refs log tree commit diff
path: root/media-fonts/tewi-font/tewi-font-9999.ebuild
diff options
context:
space:
mode:
authorazahi <azahi@teknik.io>2018-12-28 01:22:40 +0300
committerazahi <azahi@teknik.io>2018-12-28 01:22:40 +0300
commit8f2f466965f061ce6d6be4443497c0fe6e10a5bc (patch)
tree9999239cbbac3bab7497b28c44dd75cf499d7f8c /media-fonts/tewi-font/tewi-font-9999.ebuild
Initial
Diffstat (limited to 'media-fonts/tewi-font/tewi-font-9999.ebuild')
-rw-r--r--media-fonts/tewi-font/tewi-font-9999.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-fonts/tewi-font/tewi-font-9999.ebuild b/media-fonts/tewi-font/tewi-font-9999.ebuild
new file mode 100644
index 0000000..198e259
--- /dev/null
+++ b/media-fonts/tewi-font/tewi-font-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit git-r3 font python-any-r1
+
+DESCRIPTION="A small bitmap font"
+HOMEPAGE="https://github.com/lucy/tewi-font"
+EGIT_REPO_URI="https://github.com/lucy/tewi-font.git"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="+pcf"
+
+DEPEND="x11-libs/libX11
+	pcf? ( x11-apps/bdftopcf )
+"
+RDEPEND="x11-libs/libX11"
+
+src_compile() {
+	if use pcf; then
+		emake
+	else
+		emake var
+	fi
+}
+
+src_install() {
+	insinto "/usr/share/fonts/${PN}"
+
+	if use pcf; then
+		doins out/*
+	else
+		doins *.bdf
+	fi
+
+	font_src_install
+}

Consider giving Nix/NixOS a try! <3