summary refs log tree commit diff
path: root/media-fonts/uw-ttyp0/uw-ttyp0-1.3-r1.ebuild
diff options
context:
space:
mode:
authorAzat Bahawi <azahi@teknik.io>2020-11-08 13:37:04 +0300
committerAzat Bahawi <azahi@teknik.io>2020-11-08 13:37:11 +0300
commitecfa1cea20cb2207ca65049fafa1793557b8d019 (patch)
tree3d546e505b884e9e554ddfb02977d4920cc541bb /media-fonts/uw-ttyp0/uw-ttyp0-1.3-r1.ebuild
parentx11-wm/xwm: Add package (diff)
media-fonts/uw-ttyp0: Fix font encoding
There was an encoding issue that prevented the font from using
its own glyphs for languages like Russian because by default
it would prioritize creating and enabling non-UTF formats

Package-Manager: Portage-3.0.9, Repoman-3.0.2
Signed-off-by: Azat Bahawi <azahi@teknik.io>
Diffstat (limited to 'media-fonts/uw-ttyp0/uw-ttyp0-1.3-r1.ebuild')
-rw-r--r--media-fonts/uw-ttyp0/uw-ttyp0-1.3-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-fonts/uw-ttyp0/uw-ttyp0-1.3-r1.ebuild b/media-fonts/uw-ttyp0/uw-ttyp0-1.3-r1.ebuild
new file mode 100644
index 0000000..44b9e2f
--- /dev/null
+++ b/media-fonts/uw-ttyp0/uw-ttyp0-1.3-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit font
+
+DESCRIPTION="Bitmap programmer's fonts"
+HOMEPAGE="http://people.mpi-inf.mpg.de/~uwe/misc/uw-ttyp0/"
+SRC_URI="https://people.mpi-inf.mpg.de/~uwe/misc/uw-ttyp0/${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND="
+	dev-lang/perl
+	x11-apps/bdftopcf
+"
+
+src_configure() {
+	./configure prefix="${EPREFIX}/usr" pcfdir="${FONTDIR}"
+	sed -e 's/^ENCODINGS =.*/ENCODINGS = uni/' -i TARGETS.dat || die
+}
+
+src_install() {
+	emake install DESTDIR="${D}"
+}

Consider giving Nix/NixOS a try! <3