summary refs log tree commit diff
path: root/x11-misc/devour/devour-9999.ebuild
diff options
context:
space:
mode:
authorAzat Bahawi <azahi@teknik.io>2020-08-15 11:40:07 +0300
committerAzat Bahawi <azahi@teknik.io>2020-08-15 11:40:07 +0300
commitce36c85a55e9bb5a4f258018b8fc5d4a703e14e7 (patch)
tree281e2a1b535a6e0bc083fc9cc7b8228a0a5ed06f /x11-misc/devour/devour-9999.ebuild
parentMerge pull request #6 from kc-kc/master (diff)
x11-misc/devour: Add live
Diffstat (limited to 'x11-misc/devour/devour-9999.ebuild')
-rw-r--r--x11-misc/devour/devour-9999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-misc/devour/devour-9999.ebuild b/x11-misc/devour/devour-9999.ebuild
new file mode 100644
index 0000000..a79c528
--- /dev/null
+++ b/x11-misc/devour/devour-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	inherit git-r3
+	EGIT_REPO_URI="https://github.com/salman-abedin/devour.git"
+fi
+
+DESCRIPTION="Window Manager agnostic swallowing feature for terminal emulators"
+HOMEPAGE="https://github.com/salman-abedin/devour"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/salman-abedin/devour/archive/v${PV}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_install() {
+	emake DESTDIR="${D}" PREFIX="/usr" BINPREFIX="/usr/bin" install
+}

Consider giving Nix/NixOS a try! <3