summary refs log tree commit diff
path: root/x11-misc/herbe/herbe-1.0.0.ebuild
diff options
context:
space:
mode:
authorAzat Bahawi <azahi@teknik.io>2020-09-16 08:32:12 +0300
committerGitHub <noreply@github.com>2020-09-16 08:32:12 +0300
commit35b01125c83a9ec4846c35d7f4eb2c9c2539522b (patch)
tree08f18f6965ad1779e869cb37763cba02f455343a /x11-misc/herbe/herbe-1.0.0.ebuild
parentAdd Travis CI status button (diff)
parentUpdate TODO (diff)
Merge pull request #7 from caseyavila/master
x11-misc/herbe: Add package
Diffstat (limited to 'x11-misc/herbe/herbe-1.0.0.ebuild')
-rw-r--r--x11-misc/herbe/herbe-1.0.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-misc/herbe/herbe-1.0.0.ebuild b/x11-misc/herbe/herbe-1.0.0.ebuild
new file mode 100644
index 0000000..263ceab
--- /dev/null
+++ b/x11-misc/herbe/herbe-1.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit savedconfig
+
+DESCRIPTION="Daemon-less notifications without D-Bus. Minimal and lightweight."
+HOMEPAGE="https://github.com/dudik/herbe"
+SRC_URI="https://github.com/dudik/herbe/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11
+	x11-libs/libXft
+	media-libs/freetype:2
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_prepare() {
+	default
+
+	restore_config config.h
+}
+
+src_install() {
+	emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+
+	save_config config.h
+}

Consider giving Nix/NixOS a try! <3