summary refs log tree commit diff
path: root/x11-misc/herbe/herbe-1.0.0.ebuild
diff options
context:
space:
mode:
authorCasey Avila <casey@theavilas.org>2020-09-14 17:22:54 -0700
committerCasey Avila <casey@theavilas.org>2020-09-14 17:22:54 -0700
commitd5e642b78e839a5413d0a5241f65f626eb8deb3c (patch)
treed54a1f1f6c87844343b0eac12da23e5fbc08e714 /x11-misc/herbe/herbe-1.0.0.ebuild
parentAdd Travis CI status button (diff)
Add package: x11-misc/herbe
Diffstat (limited to 'x11-misc/herbe/herbe-1.0.0.ebuild')
-rw-r--r--x11-misc/herbe/herbe-1.0.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-misc/herbe/herbe-1.0.0.ebuild b/x11-misc/herbe/herbe-1.0.0.ebuild
new file mode 100644
index 0000000..263ceab
--- /dev/null
+++ b/x11-misc/herbe/herbe-1.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit savedconfig
+
+DESCRIPTION="Daemon-less notifications without D-Bus. Minimal and lightweight."
+HOMEPAGE="https://github.com/dudik/herbe"
+SRC_URI="https://github.com/dudik/herbe/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11
+	x11-libs/libXft
+	media-libs/freetype:2
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_prepare() {
+	default
+
+	restore_config config.h
+}
+
+src_install() {
+	emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+
+	save_config config.h
+}

Consider giving Nix/NixOS a try! <3