summary refs log tree commit diff
path: root/x11-misc/lemonbar/lemonbar-9999.ebuild
diff options
context:
space:
mode:
authorAzat Bahawi <azahi@teknik.io>2020-02-29 11:18:57 +0300
committerAzat Bahawi <azahi@teknik.io>2020-02-29 11:18:57 +0300
commit7250a9c0f82c65edf6af351cf1ef1c5549475a39 (patch)
treedaccc9163d0fe0f7e9619d1c35a642bf94d6c7f5 /x11-misc/lemonbar/lemonbar-9999.ebuild
parentmedia-sound/pulsemixer: Remove package (diff)
x11-misc/lemonbar: Bump EAPI, add live ebuild
Diffstat (limited to 'x11-misc/lemonbar/lemonbar-9999.ebuild')
-rw-r--r--x11-misc/lemonbar/lemonbar-9999.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-misc/lemonbar/lemonbar-9999.ebuild b/x11-misc/lemonbar/lemonbar-9999.ebuild
new file mode 100644
index 0000000..b380b24
--- /dev/null
+++ b/x11-misc/lemonbar/lemonbar-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2018-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	inherit git-r3
+	EGIT_REPO_URI="https://github.com/LemonBoy/bar.git"
+fi
+
+DESCRIPTION="A featherweight, lemon-scented, bar based on xcb"
+HOMEPAGE="https://github.com/LemonBoy/bar"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/LemonBoy/bar/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+xft"
+
+DEPEND="x11-libs/libxcb
+	xft? ( x11-libs/libXft )
+"
+RDEPEND="${DEPEND}
+	dev-lang/perl
+"
+BDEPEND=""
+
+if [[ ${PV} != *9999 ]]; then
+	S="${WORKDIR}/bar-${PV}"
+fi
+

Consider giving Nix/NixOS a try! <3