summary refs log tree commit diff
path: root/x11-misc/xgetres/xgetres-9999.ebuild
diff options
context:
space:
mode:
authorAzat Bahawi <azahi@teknik.io>2020-08-11 21:35:22 +0300
committerAzat Bahawi <azahi@teknik.io>2020-08-11 21:35:22 +0300
commit856d54199010bd8259db97d4846fb07177fb753b (patch)
treec0340c75ace3fdea6e4e289321585681710db0bc /x11-misc/xgetres/xgetres-9999.ebuild
parentUpdate TODO.md (diff)
x11-misc/xgetres: Drop 1.0, bump to live
For some reason today I couldn't build 1.0 version of this pacakge. Kept
getting some weird linkage errors related to x11-libs/libX11 functions
which is really strange. However the live build seems to work just fine,
not sure what's the problem here but the most _sane_ approach would be
to just drop 1.0 altogether.
Diffstat (limited to 'x11-misc/xgetres/xgetres-9999.ebuild')
-rw-r--r--x11-misc/xgetres/xgetres-9999.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-misc/xgetres/xgetres-9999.ebuild b/x11-misc/xgetres/xgetres-9999.ebuild
new file mode 100644
index 0000000..0b50e78
--- /dev/null
+++ b/x11-misc/xgetres/xgetres-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	SCM="git-r3"
+	EGIT_REPO_URI="https://github.com/tamirzb/xgetres.git"
+fi
+
+inherit eutils ${SCM}
+
+DESCRIPTION="A dmenu rip-off with contextual completion"
+HOMEPAGE="https://github.com/tamirzb/xgetres"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/tamirzb/xgetres/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_install() {
+	dobin ${PN}
+	doman ${PN}.1
+}

Consider giving Nix/NixOS a try! <3