summary refs log tree commit diff
path: root/x11-misc/xkb-switch/xkb-switch-1.8.5.ebuild
diff options
context:
space:
mode:
authorAzat Bahawi <azahi@teknik.io>2021-02-18 09:47:29 +0300
committerAzat Bahawi <azahi@teknik.io>2021-02-18 09:47:29 +0300
commit83b8545071988d48951c4220bc9e296ab3103219 (patch)
tree8974677d82238d5d7fd233a20bb78cf0be3b9de3 /x11-misc/xkb-switch/xkb-switch-1.8.5.ebuild
parentUpdate TODO (diff)
x11-misc/xkb-switch: Bump and add live
Package-Manager: Portage-3.0.14, Repoman-3.0.2
Diffstat (limited to 'x11-misc/xkb-switch/xkb-switch-1.8.5.ebuild')
-rw-r--r--x11-misc/xkb-switch/xkb-switch-1.8.5.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-misc/xkb-switch/xkb-switch-1.8.5.ebuild b/x11-misc/xkb-switch/xkb-switch-1.8.5.ebuild
new file mode 100644
index 0000000..b9c52a0
--- /dev/null
+++ b/x11-misc/xkb-switch/xkb-switch-1.8.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	SCM="git-r3"
+	EGIT_REPO_URI="https://github.com/ierton/xkb-switch.git"
+fi
+
+inherit cmake multilib ${SCM}
+
+DESCRIPTION="Switch your X keyboard layouts from the command line"
+HOMEPAGE="https://github.com/ierton/xkb-switch"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/ierton/xkb-switch/archive/${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+	x11-libs/libX11
+	x11-libs/libxkbfile
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_prepare() {
+	sed -e "s/DESTINATION lib/DESTINATION $(get_libdir)/" \
+		-i CMakeLists.txt
+
+	cmake_src_prepare
+	default
+}

Consider giving Nix/NixOS a try! <3