summary refs log tree commit diff
path: root/x11-misc/xmenu/xmenu-4.5.4.ebuild
diff options
context:
space:
mode:
authorAzat Bahawi <azahi@teknik.io>2021-01-10 17:48:07 +0300
committerAzat Bahawi <azahi@teknik.io>2021-01-10 17:48:07 +0300
commited9c7abbf1eeb121e4005921deb6b5c1484d4181 (patch)
tree8a1d7e0724cfaace6cadaa0ec59015d829d50ef5 /x11-misc/xmenu/xmenu-4.5.4.ebuild
parentx11-misc/xmenu: Bump version (diff)
x11-misc/xmenu: Bump version
Package-Manager: Portage-3.0.12, Repoman-3.0.2
Diffstat (limited to 'x11-misc/xmenu/xmenu-4.5.4.ebuild')
-rw-r--r--x11-misc/xmenu/xmenu-4.5.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-misc/xmenu/xmenu-4.5.4.ebuild b/x11-misc/xmenu/xmenu-4.5.4.ebuild
new file mode 100644
index 0000000..123102d
--- /dev/null
+++ b/x11-misc/xmenu/xmenu-4.5.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	SCM="git-r3"
+	EGIT_REPO_URI="https://github.com/phillbush/xmenu.git"
+fi
+
+inherit eutils ${SCM}
+
+DESCRIPTION="a x11 menu utility"
+HOMEPAGE="https://github.com/phillbush/xmenu"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/phillbush/xmenu/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="media-libs/fontconfig
+	media-libs/imlib2
+	x11-libs/libX11
+	x11-libs/libXft
+	x11-libs/libXinerama
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_install() {
+	emake PREFIX= DESTDIR="${D}" MANPREFIX="/usr/share/man" install
+}

Consider giving Nix/NixOS a try! <3