summary refs log tree commit diff
path: root/x11-wm/custard/custard-9999-r1.ebuild
diff options
context:
space:
mode:
authorAzat Bahawi <azahi@teknik.io>2020-11-26 01:10:23 +0300
committerAzat Bahawi <azahi@teknik.io>2020-11-26 01:10:26 +0300
commit6ad2709c83395de1dc2760d58fa6174526645bbf (patch)
tree79ff104e2881c0f05a387af51bd47ab2d38315b8 /x11-wm/custard/custard-9999-r1.ebuild
parentx11-wm/9wm: Fix CC exporting in build (diff)
x11-wm/custard: Fix build
Only builds with MAKEOPTS="-j1"

Package-Manager: Portage-3.0.10, Repoman-3.0.2
Signed-off-by: Azat Bahawi <azahi@teknik.io>
Diffstat (limited to 'x11-wm/custard/custard-9999-r1.ebuild')
-rw-r--r--x11-wm/custard/custard-9999-r1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/x11-wm/custard/custard-9999-r1.ebuild b/x11-wm/custard/custard-9999-r1.ebuild
new file mode 100644
index 0000000..f6b7496
--- /dev/null
+++ b/x11-wm/custard/custard-9999-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	SCM="git-r3"
+	EGIT_REPO_URI="https://github.com/comfies/custard.git"
+fi
+
+inherit toolchain-funcs "${SCM}"
+
+DESCRIPTION="Manual tiling window manager"
+HOMEPAGE="https://github.com/comfies/custard"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/comfies/custard/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+	dev-libs/libpcre
+	x11-libs/xcb-util
+	x11-libs/xcb-util-wm
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_prepare() {
+	default
+
+	sed -e 's/^CFLAGS.*=/CFLAGS +=/' \
+		-e 's/ -O2//' \
+		-e 's/^CPPFLAGS.*=/CPPFLAGS +=/' \
+		-e 's/^LDFLAGS.*=/LDFLAGS +=/' \
+		-i Makefile || die
+}
+
+src_compile() {
+	emake \
+		CC="$(tc-getCC)"
+}
+
+src_install() {
+	emake install \
+		DESTDIR="${D}" \
+		PREFIX="${EPREFIX}/usr"
+	newman man/${PN}.man ${PN}.1
+}

Consider giving Nix/NixOS a try! <3