summary refs log tree commit diff
path: root/x11-wm/shod/shod-0.3.1.ebuild
diff options
context:
space:
mode:
authorAzat Bahawi <azahi@teknik.io>2021-02-18 18:21:05 +0300
committerAzat Bahawi <azahi@teknik.io>2021-02-18 18:21:09 +0300
commit110a6721364743b61e2c306fc5c0df738c0a6414 (patch)
treeaa0a31770b47e298d96184544521b069aa892d47 /x11-wm/shod/shod-0.3.1.ebuild
parentapp-misc/tty-clock: Fix build and deps (diff)
x11-wm/shod: Bump version
Package-Manager: Portage-3.0.14, Repoman-3.0.2
Signed-off-by: Azat Bahawi <azahi@teknik.io>
Diffstat (limited to 'x11-wm/shod/shod-0.3.1.ebuild')
-rw-r--r--x11-wm/shod/shod-0.3.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-wm/shod/shod-0.3.1.ebuild b/x11-wm/shod/shod-0.3.1.ebuild
new file mode 100644
index 0000000..fd3f1ad
--- /dev/null
+++ b/x11-wm/shod/shod-0.3.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	inherit git-r3
+	EGIT_REPO_URI="https://github.com/phillbush/shod.git"
+fi
+
+DESCRIPTION="Hybrid (floating and tiling) window manager"
+HOMEPAGE="https://github.com/phillbush/shod"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/phillbush/shod/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+	x11-libs/libX11
+	x11-libs/libXinerama
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_prepare() {
+	sed -e '/^CPPFLAGS/d' \
+		-e 's/FLAGS =/FLAGS +=/g' \
+		-i config.mk || die
+
+	default
+}
+
+src_install() {
+	emake install \
+		DESTDIR="${D}" \
+		PREFIX="${EPREFIX}/usr"
+}

Consider giving Nix/NixOS a try! <3