summary refs log tree commit diff
path: root/x11-wm/wmutils/wmutils-1.5.ebuild
diff options
context:
space:
mode:
authorazahi <azahi@teknik.io>2019-11-03 13:58:47 +0300
committerazahi <azahi@teknik.io>2019-11-03 13:58:47 +0300
commita9252919a7fbc036eb861cc551b3097c4393d931 (patch)
treea69e6cfd66d6d057be577fad4b89911bd0863cc8 /x11-wm/wmutils/wmutils-1.5.ebuild
parentdev-libs/libwm: Add package (diff)
x11-wm/wmutils: Remove stale ebuilds, bump version, add a live ebuild
Diffstat (limited to 'x11-wm/wmutils/wmutils-1.5.ebuild')
-rw-r--r--x11-wm/wmutils/wmutils-1.5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-wm/wmutils/wmutils-1.5.ebuild b/x11-wm/wmutils/wmutils-1.5.ebuild
new file mode 100644
index 0000000..c5eea5f
--- /dev/null
+++ b/x11-wm/wmutils/wmutils-1.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	SCM="git-r3"
+	EGIT_REPO_URI="https://github.com/wmutils/core"
+fi
+
+inherit ${SCM}
+
+DESCRIPTION="Set of window manipulation tools"
+HOMEPAGE="https://github.com/wmutils/core"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/wmutils/core/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE=""
+
+DEPEND="x11-libs/libxcb"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+if [[ ${PV} != *9999 ]]; then
+	S="${WORKDIR}/core-${PV}"
+fi
+
+src_prepare() {
+	default
+
+	sed -e 's/\/man/\/share\/man/' -i config.mk || die
+}

Consider giving Nix/NixOS a try! <3