summary refs log tree commit diff
path: root/x11-wm/xwm/xwm-0.1.3.ebuild
diff options
context:
space:
mode:
authorAzat Bahawi <azahi@teknik.io>2020-12-05 12:30:35 +0300
committerAzat Bahawi <azahi@teknik.io>2020-12-05 12:30:35 +0300
commiteafcd144cb35f14ca7fd4efc0d767e871d261156 (patch)
tree41b3aaa10da41b5e01b447dd42db1ed6d42f4162 /x11-wm/xwm/xwm-0.1.3.ebuild
parentx11-misc/xnotify: Bump version (diff)
x11-wm/xwm: Bump version
Package-Manager: Portage-3.0.11, Repoman-3.0.2
Diffstat (limited to 'x11-wm/xwm/xwm-0.1.3.ebuild')
-rw-r--r--x11-wm/xwm/xwm-0.1.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-wm/xwm/xwm-0.1.3.ebuild b/x11-wm/xwm/xwm-0.1.3.ebuild
new file mode 100644
index 0000000..b4a41b1
--- /dev/null
+++ b/x11-wm/xwm/xwm-0.1.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	SCM="git-r3"
+	EGIT_REPO_URI="https://github.com/mcpcpc/xwm.git"
+fi
+
+inherit toolchain-funcs ${SCM}
+
+DESCRIPTION="A tiny XCB floating window manager"
+HOMEPAGE="https://github.com/mcpcpc/xwm"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/mcpcpc/xwm/archive/${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+	x11-libs/libxcb
+	x11-libs/xcb-util-keysyms
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+DOCS=( README )
+
+src_compile() {
+	emake CC="$(tc-getCC)"
+}
+
+src_install() {
+	emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+	einstalldocs
+}

Consider giving Nix/NixOS a try! <3