summary refs log tree commit diff
path: root/x11-wm/xwm/xwm-0.1.7.ebuild
diff options
context:
space:
mode:
authorAzat Bahawi <azahi@teknik.io>2021-03-04 19:30:14 +0300
committerAzat Bahawi <azahi@teknik.io>2021-03-04 19:30:19 +0300
commitac3b550db3dae41f652c9767a6e69ecf6fb064dd (patch)
treea108ec29f8149cd06e0aadc88bcc6c5c4808413a /x11-wm/xwm/xwm-0.1.7.ebuild
parentx11-wm/shod: Fix CC and install docs (diff)
x11-wm/xwm: Bump version and refactor
Package-Manager: Portage-3.0.16, Repoman-3.0.2
Signed-off-by: Azat Bahawi <azahi@teknik.io>
Diffstat (limited to 'x11-wm/xwm/xwm-0.1.7.ebuild')
-rw-r--r--x11-wm/xwm/xwm-0.1.7.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/x11-wm/xwm/xwm-0.1.7.ebuild b/x11-wm/xwm/xwm-0.1.7.ebuild
new file mode 100644
index 0000000..ae10afc
--- /dev/null
+++ b/x11-wm/xwm/xwm-0.1.7.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	SCM="git-r3"
+	EGIT_REPO_URI="https://github.com/mcpcpc/xwm.git"
+fi
+
+inherit toolchain-funcs ${SCM}
+
+DESCRIPTION="A tiny XCB floating window manager"
+HOMEPAGE="https://github.com/mcpcpc/xwm"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/mcpcpc/xwm/archive/${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+	x11-libs/libxcb
+	x11-libs/xcb-util-keysyms
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+DOCS=(
+	README
+)
+
+src_compile() {
+	emake CC="$(tc-getCC)"
+}
+
+src_install() {
+	emake install \
+		DESTDIR="${D}" \
+		PREFIX="${EPREFIX}/usr"
+
+	einstalldocs
+}

Consider giving Nix/NixOS a try! <3