summary refs log tree commit diff
path: root/dev-util/bear/bear-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/bear/bear-9999.ebuild')
-rw-r--r--dev-util/bear/bear-9999.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/bear/bear-9999.ebuild b/dev-util/bear/bear-9999.ebuild
new file mode 100644
index 0000000..c0a15c9
--- /dev/null
+++ b/dev-util/bear/bear-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	SCM="git-r3"
+	EGIT_REPO_URI="https://github.com/rizsotto/Bear"
+fi
+
+inherit cmake-utils ${SCM}
+
+DESCRIPTION="Compilation database generator for Clang"
+HOMEPAGE="https://github.com/rizsotto/Bear"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/rizsotto/Bear/archive/${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-libs/libconfig-1.4"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"

Consider giving Nix/NixOS a try! <3