summary refs log tree commit diff
path: root/dev-util/ccls/ccls-0.20190823.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/ccls/ccls-0.20190823.4.ebuild')
-rw-r--r--dev-util/ccls/ccls-0.20190823.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/ccls/ccls-0.20190823.4.ebuild b/dev-util/ccls/ccls-0.20190823.4.ebuild
new file mode 100644
index 0000000..771bf67
--- /dev/null
+++ b/dev-util/ccls/ccls-0.20190823.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	SCM="git-r3"
+	EGIT_REPO_URI="https://github.com/MaskRay/${PN}"
+fi
+
+inherit cmake-utils ${SCM}
+
+DESCRIPTION="C/C++/ObjC language server"
+HOMEPAGE="https://github.com/MaskRay/ccls"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/MaskRay/ccls/archive/${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+>=sys-devel/clang-5.0:=
+>=sys-devel/llvm-7.0:=
+dev-libs/rapidjson
+sys-libs/ncurses
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""

Consider giving Nix/NixOS a try! <3