summary refs log tree commit diff
path: root/x11-misc/sflock/sflock-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/sflock/sflock-9999.ebuild')
-rw-r--r--x11-misc/sflock/sflock-9999.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-misc/sflock/sflock-9999.ebuild b/x11-misc/sflock/sflock-9999.ebuild
new file mode 100644
index 0000000..b09b8ba
--- /dev/null
+++ b/x11-misc/sflock/sflock-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	SCM="git-r3"
+	EGIT_REPO_URI="https://github.com/benruijl/sflock.git"
+fi
+
+inherit eutils ${SCM}
+
+DESCRIPTION="focus the closest window in a given direction"
+HOMEPAGE="https://github.com/benruijl/sflock"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/benruijl/sflock/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_prepare() {
+	sed -e 's/-Os //' -i config.mk || die
+	sed -e 's/-s //' -i config.mk || die
+	default
+}
+
+src_install() {
+	emake PREFIX="/usr" DESTDIR="${D}" install
+}

Consider giving Nix/NixOS a try! <3