summary refs log tree commit diff
path: root/x11-misc/xprompt/xprompt-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xprompt/xprompt-9999.ebuild')
-rw-r--r--x11-misc/xprompt/xprompt-9999.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-misc/xprompt/xprompt-9999.ebuild b/x11-misc/xprompt/xprompt-9999.ebuild
new file mode 100644
index 0000000..1185878
--- /dev/null
+++ b/x11-misc/xprompt/xprompt-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	SCM="git-r3"
+	EGIT_REPO_URI="https://github.com/phillbush/xprompt.git"
+fi
+
+inherit eutils ${SCM}
+
+DESCRIPTION="A dmenu rip-off with contextual completion"
+HOMEPAGE="https://github.com/phillbush/xprompt"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/phillbush/xprompt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="x11-libs/libX11
+	x11-libs/libXft
+	x11-libs/libXinerama
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_install() {
+	emake PREFIX= DESTDIR="${D}" MANPREFIX="/usr/share/man" install
+}

Consider giving Nix/NixOS a try! <3