summary refs log tree commit diff
path: root/x11-wm/2bwm/2bwm-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/2bwm/2bwm-9999.ebuild')
-rw-r--r--x11-wm/2bwm/2bwm-9999.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/x11-wm/2bwm/2bwm-9999.ebuild b/x11-wm/2bwm/2bwm-9999.ebuild
new file mode 100644
index 0000000..51d6f46
--- /dev/null
+++ b/x11-wm/2bwm/2bwm-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	SCM="git-r3"
+	EGIT_REPO_URI="https://github.com/venam/2bwm"
+fi
+
+inherit savedconfig ${SCM}
+
+DESCRIPTION="A fast floating WM written over the XCB library and derived from mcwm."
+HOMEPAGE="https://github.com/venam/2bwm"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/venam/2bwm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE=""
+
+DEPEND="x11-libs/xcb-util
+	x11-libs/xcb-util-renderutil
+	x11-libs/xcb-util-wm
+	x11-libs/xcb-util-xrm
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_compile() {
+	restore_config config.h
+}
+
+src_install() {
+	emake DESTDIR="${D}" PREFIX=/usr install
+	save_config config.h
+}

Consider giving Nix/NixOS a try! <3