summary refs log tree commit diff
path: root/x11-wm/9wm/9wm-9999-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/9wm/9wm-9999-r1.ebuild')
-rw-r--r--x11-wm/9wm/9wm-9999-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-wm/9wm/9wm-9999-r1.ebuild b/x11-wm/9wm/9wm-9999-r1.ebuild
new file mode 100644
index 0000000..61236a7
--- /dev/null
+++ b/x11-wm/9wm/9wm-9999-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	SCM="git-r3"
+	EGIT_REPO_URI="https://github.com/9wm/9wm.git"
+fi
+
+inherit toolchain-funcs "${SCM}"
+
+DESCRIPTION="X11 window manager inspired by Plan 9's rio"
+HOMEPAGE="https://github.com/9wm/9wm"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/9wm/9wm/archive/${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+	x11-libs/libX11
+	x11-libs/libXext
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+DOCS=( CREDITS.md CUSTOMIZING.md README.md )
+
+src_compile() {
+	emake \
+		CC="$(tc-getCC)"
+}
+
+src_install() {
+	default
+	newman ${PN}.man ${PN}.1
+}

Consider giving Nix/NixOS a try! <3