summary refs log tree commit diff
path: root/x11-wm/wmutils-opt/wmutils-opt-1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/wmutils-opt/wmutils-opt-1.0.ebuild')
-rw-r--r--x11-wm/wmutils-opt/wmutils-opt-1.0.ebuild34
1 files changed, 22 insertions, 12 deletions
diff --git a/x11-wm/wmutils-opt/wmutils-opt-1.0.ebuild b/x11-wm/wmutils-opt/wmutils-opt-1.0.ebuild
index f00901d..1f61ac8 100644
--- a/x11-wm/wmutils-opt/wmutils-opt-1.0.ebuild
+++ b/x11-wm/wmutils-opt/wmutils-opt-1.0.ebuild
@@ -1,24 +1,34 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-DESCRIPTION="Optional addons to wmutils"
+if [[ ${PV} == *9999 ]]; then
+	SCM="git-r3"
+	EGIT_REPO_URI="https://github.com/wmutils/opt"
+fi
+
+inherit ${SCM}
+
+DESCRIPTION="Set of window manipulation tools"
 HOMEPAGE="https://github.com/wmutils/opt"
-SRC_URI="https://github.com/wmutils/opt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/wmutils/opt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
 
 LICENSE="ISC"
 SLOT="0"
-KEYWORDS="~amd64"
 IUSE=""
 
 DEPEND="x11-libs/libxcb"
 RDEPEND="${DEPEND}"
+BDEPEND=""
 
-S="${WORKDIR}/opt-${PV}"
-
-src_prepare() {
-	default
-
-	sed -e 's/\ -Os//' -i config.mk || die
-}
+if [[ ${PV} != *9999 ]]; then
+	S="${WORKDIR}/opt-${PV}"
+fi

Consider giving Nix/NixOS a try! <3