about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azahi@teknik.io>2021-12-08 05:10:08 +0300
committerAzat Bahawi <azahi@teknik.io>2021-12-08 05:10:08 +0300
commitb68523ec9c38bd86f65edfb6687d2b767a0a74b4 (patch)
tree51b4547d07dec6522269c5a95e8a7a7cf2120c4c /flake.nix
parentTest gitlab CI (diff)
Test
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/flake.nix b/flake.nix
index 7d2c900..426f9bd 100644
--- a/flake.nix
+++ b/flake.nix
@@ -29,7 +29,7 @@
   outputs = { self, nixpkgs, flake-utils, ... }:
     flake-utils.lib.eachDefaultSystem (system:
       let
-        pkgs = import nixpkgs { inherit system; };
+        pkgs = nixpkgs.legacyPackages.${system};
 
         project = returnShellEnv:
           pkgs.haskellPackages.developPackage {
@@ -57,8 +57,8 @@
       in {
         defaultPackage = project false;
 
-        overlay = _: _: { xmonad-ng = self.defaultPackage.${system}; };
-
         devShell = project true;
-      });
+      }) // {
+        overlay = _: _: { xmonad-ng = self.defaultPackage; };
+      };
 }

Consider giving Nix/NixOS a try! <3