about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix10
1 files changed, 6 insertions, 4 deletions
diff --git a/flake.nix b/flake.nix
index 985cc57..39a96f9 100644
--- a/flake.nix
+++ b/flake.nix
@@ -68,7 +68,9 @@
               ]);
           };
       in {
-        defaultPackage = project false;
+        packages.${name} = project false;
+
+        defaultPackage = self.packages.${system}.${name};
 
         checks.preCommit = pre-commit-hooks.lib.${system}.run {
           src = ./.;
@@ -102,7 +104,7 @@
         };
 
         devShell = self.devShells.${system}.dev;
-      }) // {
-        overlay = _: _: { ${name} = self.defaultPackage; };
-      };
+
+        overlay = _: _: { ${name} = self.defaultPackage.${system}; };
+      });
 }

Consider giving Nix/NixOS a try! <3