summaryrefslogtreecommitdiff
path: root/configurations/iso/default.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-05-01 03:36:55 +0300
committerAzat Bahawi <azat@bahawi.net>2024-05-01 03:36:55 +0300
commit9a20404924fda2587ce4f9769f75369799f34643 (patch)
treea953941a22d6c031e67b267e35a11db72bdd25e3 /configurations/iso/default.nix
parentc1353bb04b594a8b11fa7e28dbf29d0a6cb08275 (diff)
2024-05-01
Diffstat (limited to 'configurations/iso/default.nix')
-rw-r--r--configurations/iso/default.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/configurations/iso/default.nix b/configurations/iso/default.nix
new file mode 100644
index 0000000..7277e88
--- /dev/null
+++ b/configurations/iso/default.nix
@@ -0,0 +1,26 @@
+{ lib, ... }:
+with lib;
+{
+ secrets = mkForce { };
+
+ nixfiles.modules = {
+ common.networking.onlyDefault = true;
+ git.client.enable = true;
+ gnupg.enable = true;
+ openssh = {
+ client.enable = true;
+ server = {
+ enable = true;
+ port = 22;
+ };
+ };
+ };
+
+ hm.programs.git.signing.signByDefault = mkForce false;
+
+ programs.mtr.enable = true;
+
+ services.getty.autologinUser = mkForce my.username;
+
+ nixpkgs.config.allowBroken = true;
+}