summaryrefslogtreecommitdiff
path: root/configurations/iso/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configurations/iso/default.nix')
-rw-r--r--configurations/iso/default.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/configurations/iso/default.nix b/configurations/iso/default.nix
new file mode 100644
index 0000000..7277e88
--- /dev/null
+++ b/configurations/iso/default.nix
@@ -0,0 +1,26 @@
+{ lib, ... }:
+with lib;
+{
+ secrets = mkForce { };
+
+ nixfiles.modules = {
+ common.networking.onlyDefault = true;
+ git.client.enable = true;
+ gnupg.enable = true;
+ openssh = {
+ client.enable = true;
+ server = {
+ enable = true;
+ port = 22;
+ };
+ };
+ };
+
+ hm.programs.git.signing.signByDefault = mkForce false;
+
+ programs.mtr.enable = true;
+
+ services.getty.autologinUser = mkForce my.username;
+
+ nixpkgs.config.allowBroken = true;
+}