summaryrefslogtreecommitdiff
path: root/darwinConfigurations/default.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-03-31 21:29:27 +0300
committerAzat Bahawi <azat@bahawi.net>2024-03-31 21:29:27 +0300
commit9a5427e3a0c0ccf2a82dc503149a26b23fbd6004 (patch)
treef28beec29deeea36038615a8fb98a810891940b5 /darwinConfigurations/default.nix
parent4ad0c3afc1f6caf0c3f05f99a15b22178f2c190b (diff)
2024-03-31
Diffstat (limited to 'darwinConfigurations/default.nix')
-rw-r--r--darwinConfigurations/default.nix61
1 files changed, 32 insertions, 29 deletions
diff --git a/darwinConfigurations/default.nix b/darwinConfigurations/default.nix
index b8f1498..0e19d26 100644
--- a/darwinConfigurations/default.nix
+++ b/darwinConfigurations/default.nix
@@ -1,33 +1,36 @@
inputs:
-with inputs.self.lib; let
- mkConfiguration = name: {
- modules ? [],
- configuration ? ./${name},
- this ? my.configurations.${name},
- extraSpecialArgs ? {
- localUsername = my.username;
- localHostname = this.hostname;
- },
- }:
- nameValuePair name (inputs.darwin.lib.darwinSystem {
- inherit (this) system;
- modules =
- modules
- ++ attrValues inputs.self.modules
- ++ attrValues inputs.self.darwinModules
- ++ optional (configuration != null) (import configuration);
- specialArgs =
- {
+with inputs.self.lib;
+let
+ mkConfiguration =
+ name:
+ {
+ modules ? [ ],
+ configuration ? ./${name},
+ this ? my.configurations.${name},
+ extraSpecialArgs ? {
+ localUsername = my.username;
+ localHostname = this.hostname;
+ },
+ }:
+ nameValuePair name (
+ inputs.darwin.lib.darwinSystem {
+ inherit (this) system;
+ modules =
+ modules
+ ++ attrValues inputs.self.modules
+ ++ attrValues inputs.self.darwinModules
+ ++ optional (configuration != null) (import configuration);
+ specialArgs = {
inherit inputs this;
inherit (inputs.self) lib;
- }
- // extraSpecialArgs;
- });
+ } // extraSpecialArgs;
+ }
+ );
in
- mapAttrs' mkConfiguration {
- mairon.extraSpecialArgs = {
- # These values are managed by my employer.
- localUsername = "username";
- localHostname = "hostname";
- };
- }
+mapAttrs' mkConfiguration {
+ mairon.extraSpecialArgs = {
+ # These values are managed by my employer.
+ localUsername = "username";
+ localHostname = "hostname";
+ };
+}