summaryrefslogtreecommitdiff
path: root/darwinConfigurations/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'darwinConfigurations/default.nix')
-rw-r--r--darwinConfigurations/default.nix61
1 files changed, 32 insertions, 29 deletions
diff --git a/darwinConfigurations/default.nix b/darwinConfigurations/default.nix
index b8f1498..0e19d26 100644
--- a/darwinConfigurations/default.nix
+++ b/darwinConfigurations/default.nix
@@ -1,33 +1,36 @@
inputs:
-with inputs.self.lib; let
- mkConfiguration = name: {
- modules ? [],
- configuration ? ./${name},
- this ? my.configurations.${name},
- extraSpecialArgs ? {
- localUsername = my.username;
- localHostname = this.hostname;
- },
- }:
- nameValuePair name (inputs.darwin.lib.darwinSystem {
- inherit (this) system;
- modules =
- modules
- ++ attrValues inputs.self.modules
- ++ attrValues inputs.self.darwinModules
- ++ optional (configuration != null) (import configuration);
- specialArgs =
- {
+with inputs.self.lib;
+let
+ mkConfiguration =
+ name:
+ {
+ modules ? [ ],
+ configuration ? ./${name},
+ this ? my.configurations.${name},
+ extraSpecialArgs ? {
+ localUsername = my.username;
+ localHostname = this.hostname;
+ },
+ }:
+ nameValuePair name (
+ inputs.darwin.lib.darwinSystem {
+ inherit (this) system;
+ modules =
+ modules
+ ++ attrValues inputs.self.modules
+ ++ attrValues inputs.self.darwinModules
+ ++ optional (configuration != null) (import configuration);
+ specialArgs = {
inherit inputs this;
inherit (inputs.self) lib;
- }
- // extraSpecialArgs;
- });
+ } // extraSpecialArgs;
+ }
+ );
in
- mapAttrs' mkConfiguration {
- mairon.extraSpecialArgs = {
- # These values are managed by my employer.
- localUsername = "username";
- localHostname = "hostname";
- };
- }
+mapAttrs' mkConfiguration {
+ mairon.extraSpecialArgs = {
+ # These values are managed by my employer.
+ localUsername = "username";
+ localHostname = "hostname";
+ };
+}