summaryrefslogtreecommitdiff
path: root/darwinConfigurations/default.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
committerAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
commite6ed60548397627bf10f561f9438201dbba0a36e (patch)
treef9a84c5957d2cc4fcd148065ee9365a0c851ae1c /darwinConfigurations/default.nix
parent9ac64328603d44bd272175942d3ea3eaadcabd04 (diff)
2024-04-21
Diffstat (limited to 'darwinConfigurations/default.nix')
-rw-r--r--darwinConfigurations/default.nix36
1 files changed, 0 insertions, 36 deletions
diff --git a/darwinConfigurations/default.nix b/darwinConfigurations/default.nix
deleted file mode 100644
index 0e19d26..0000000
--- a/darwinConfigurations/default.nix
+++ /dev/null
@@ -1,36 +0,0 @@
-inputs:
-with inputs.self.lib;
-let
- mkConfiguration =
- name:
- {
- modules ? [ ],
- configuration ? ./${name},
- this ? my.configurations.${name},
- extraSpecialArgs ? {
- localUsername = my.username;
- localHostname = this.hostname;
- },
- }:
- nameValuePair name (
- inputs.darwin.lib.darwinSystem {
- inherit (this) system;
- modules =
- modules
- ++ attrValues inputs.self.modules
- ++ attrValues inputs.self.darwinModules
- ++ optional (configuration != null) (import configuration);
- specialArgs = {
- inherit inputs this;
- inherit (inputs.self) lib;
- } // extraSpecialArgs;
- }
- );
-in
-mapAttrs' mkConfiguration {
- mairon.extraSpecialArgs = {
- # These values are managed by my employer.
- localUsername = "username";
- localHostname = "hostname";
- };
-}