summaryrefslogtreecommitdiff
path: root/darwinConfigurations/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'darwinConfigurations/default.nix')
-rw-r--r--darwinConfigurations/default.nix36
1 files changed, 0 insertions, 36 deletions
diff --git a/darwinConfigurations/default.nix b/darwinConfigurations/default.nix
deleted file mode 100644
index 0e19d26..0000000
--- a/darwinConfigurations/default.nix
+++ /dev/null
@@ -1,36 +0,0 @@
-inputs:
-with inputs.self.lib;
-let
- mkConfiguration =
- name:
- {
- modules ? [ ],
- configuration ? ./${name},
- this ? my.configurations.${name},
- extraSpecialArgs ? {
- localUsername = my.username;
- localHostname = this.hostname;
- },
- }:
- nameValuePair name (
- inputs.darwin.lib.darwinSystem {
- inherit (this) system;
- modules =
- modules
- ++ attrValues inputs.self.modules
- ++ attrValues inputs.self.darwinModules
- ++ optional (configuration != null) (import configuration);
- specialArgs = {
- inherit inputs this;
- inherit (inputs.self) lib;
- } // extraSpecialArgs;
- }
- );
-in
-mapAttrs' mkConfiguration {
- mairon.extraSpecialArgs = {
- # These values are managed by my employer.
- localUsername = "username";
- localHostname = "hostname";
- };
-}