summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-05-26 14:01:02 +0300
committerAzat Bahawi <azat@bahawi.net>2024-05-26 14:01:02 +0300
commit1831d54b47e0ca1aa16b39fc3ab1ffcd538c6622 (patch)
tree96a4f898f0ff2398da5283ef4ea8314fe8ad78d2 /flake.nix
parent364e8a98ad25127f2a51696ec03729e3a783044f (diff)
2024-05-26
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix50
1 files changed, 9 insertions, 41 deletions
diff --git a/flake.nix b/flake.nix
index 9e78601..1019a60 100644
--- a/flake.nix
+++ b/flake.nix
@@ -189,6 +189,8 @@
legacyPackages.${system} = pkgs;
+ overlays = import ./overlays.nix;
+
devShells.${system}.default =
with pkgs;
mkShell {
@@ -198,49 +200,15 @@
formatter.${system} = pkgs.nixfmt;
- checks.${system} = import ./checks.nix {
- inherit
- inputs
- lib
- pkgs
- system
- ;
- };
-
- nixosModules = import ./modules {
- inherit
- inputs
- lib
- pkgs
- system
- ;
- };
+ checks.${system} = import ./checks.nix { inherit inputs pkgs system; };
- nixosConfigurations = import ./configurations {
- inherit
- inputs
- lib
- pkgs
- system
- ;
- };
+ nixosModules.nixfiles =
+ _: with lib; {
+ imports = attrValues (modulesIn ./modules);
+ };
- overlays = import ./overlays.nix {
- inherit
- inputs
- lib
- pkgs
- system
- ;
- };
+ nixosConfigurations = import ./configurations { inherit inputs lib pkgs; };
- topology = import ./topology.nix {
- inherit
- inputs
- lib
- pkgs
- system
- ;
- };
+ topology = import ./topology.nix { inherit inputs lib pkgs; };
};
}