summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-06-27 18:10:21 +0300
committerAzat Bahawi <azat@bahawi.net>2024-06-27 18:10:21 +0300
commitb212b16a14ea12384c4b19ad453076502855a738 (patch)
treedefd42780c334342e82d59ac927ae070e9af5fd7 /flake.nix
parent75918debfd7245d90478f882b0323a705ab3c7be (diff)
2024-06-27
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 727ba2f..652f0f2 100644
--- a/flake.nix
+++ b/flake.nix
@@ -17,6 +17,11 @@
inputs.nixpkgs.follows = "nixpkgs";
};
+ disko = {
+ url = "github:nix-community/disko";
+ inputs.nixpkgs.follows = "nixpkgs";
+ };
+
srvos = {
url = "github:nix-community/srvos";
inputs.nixpkgs.follows = "nixpkgs";
@@ -196,7 +201,7 @@
checks.${system} = import ./checks.nix { inherit inputs pkgs system; };
- nixosModules.nixfiles =
+ nixosModules.default =
_: with lib; {
imports = attrValues (modulesIn ./modules);
};