summaryrefslogtreecommitdiff
path: root/modules/darwin/profiles/default.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-03-31 21:29:27 +0300
committerAzat Bahawi <azat@bahawi.net>2024-03-31 21:29:27 +0300
commit9a5427e3a0c0ccf2a82dc503149a26b23fbd6004 (patch)
treef28beec29deeea36038615a8fb98a810891940b5 /modules/darwin/profiles/default.nix
parent4ad0c3afc1f6caf0c3f05f99a15b22178f2c190b (diff)
2024-03-31
Diffstat (limited to 'modules/darwin/profiles/default.nix')
-rw-r--r--modules/darwin/profiles/default.nix16
1 files changed, 8 insertions, 8 deletions
diff --git a/modules/darwin/profiles/default.nix b/modules/darwin/profiles/default.nix
index c18f2bb..9a3353f 100644
--- a/modules/darwin/profiles/default.nix
+++ b/modules/darwin/profiles/default.nix
@@ -4,21 +4,21 @@
pkgs,
...
}:
-with lib; let
+with lib;
+let
cfg = config.nixfiles.modules.profiles.default;
-in {
- imports = [
- ./headful.nix
- ];
+in
+{
+ imports = [ ./headful.nix ];
config = mkIf cfg.enable {
- hm.home.packages = with pkgs; [m-cli];
+ hm.home.packages = with pkgs; [ m-cli ];
system = {
defaults = {
- CustomUserPreferences = {};
+ CustomUserPreferences = { };
- ActivityMonitor = {};
+ ActivityMonitor = { };
NSGlobalDomain = {
AppleEnableMouseSwipeNavigateWithScrolls = true;