summaryrefslogtreecommitdiff
path: root/modules/darwin/profiles/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/darwin/profiles/default.nix')
-rw-r--r--modules/darwin/profiles/default.nix16
1 files changed, 8 insertions, 8 deletions
diff --git a/modules/darwin/profiles/default.nix b/modules/darwin/profiles/default.nix
index c18f2bb..9a3353f 100644
--- a/modules/darwin/profiles/default.nix
+++ b/modules/darwin/profiles/default.nix
@@ -4,21 +4,21 @@
pkgs,
...
}:
-with lib; let
+with lib;
+let
cfg = config.nixfiles.modules.profiles.default;
-in {
- imports = [
- ./headful.nix
- ];
+in
+{
+ imports = [ ./headful.nix ];
config = mkIf cfg.enable {
- hm.home.packages = with pkgs; [m-cli];
+ hm.home.packages = with pkgs; [ m-cli ];
system = {
defaults = {
- CustomUserPreferences = {};
+ CustomUserPreferences = { };
- ActivityMonitor = {};
+ ActivityMonitor = { };
NSGlobalDomain = {
AppleEnableMouseSwipeNavigateWithScrolls = true;