summaryrefslogtreecommitdiff
path: root/modules/emacs.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
committerAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
commite6ed60548397627bf10f561f9438201dbba0a36e (patch)
treef9a84c5957d2cc4fcd148065ee9365a0c851ae1c /modules/emacs.nix
parent9ac64328603d44bd272175942d3ea3eaadcabd04 (diff)
2024-04-21
Diffstat (limited to 'modules/emacs.nix')
-rw-r--r--modules/emacs.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/modules/emacs.nix b/modules/emacs.nix
new file mode 100644
index 0000000..8a59c9b
--- /dev/null
+++ b/modules/emacs.nix
@@ -0,0 +1,19 @@
+{ config, lib, ... }:
+with lib;
+let
+ cfg = config.nixfiles.modules.emacs;
+in
+{
+ config = mkIf cfg.enable {
+ nixfiles.modules.common.xdg.defaultApplications.emacs = [
+ "application/atom+xml"
+ "application/json"
+ "application/rss+xml"
+ "application/schema+json"
+ "application/xhtml+xml"
+ "application/xml"
+ "text/csv"
+ "text/plain"
+ ];
+ };
+}